Monobrick does not boot (my first attempt)

HomeForumsMonoBrick EV3 FirmwareMonobrick does not boot (my first attempt)

This topic contains 7 replies, has 2 voices, and was last updated by Author Image Anders Søborg 3 years, 3 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #4272
    Author Image
    Henrik Kurka
    Participant

    I have just created the SD card on my Mac acccording to the instructions (did it even twice), but when I boot my EV3, the display continues to display “Mindstorms starting…” a loong time after the orange lights have turned off. Nothing happens and I have waited for at least ten minutes. No Monobrick logo to be seen :(

    I have a 2GB MicroSD card from SanDisk and created the image using imagefile_2GB.img

    If I pull out the SD card and reboot the brick it boots just fine into standard EV3.

    Files on the SD-card:
    ls -l
    total 3844
    -rwxrwxrwx 1 Henrik staff 1965028 Dec 23 17:29 uImage
    -rwxrwxrwx 1 Henrik staff 201 Dec 23 17:29 wpa_supplicant.conf

    Any ideas?

    Attachments:
    You must be logged in to view attached files.
    #4276
    Author Image
    Anders Søborg
    Key Master

    Hi

    Try to use the 512mb image…

    Anders

    #4280
    Author Image
    Henrik Kurka
    Participant

    Hi. Thanks for the suggestion. Actually I tried that earlier today, but it did not work either. One difference is that the red light never turned off, but it didnt complete booting anyway :(

    #4286
    Author Image
    Anders Søborg
    Key Master

    Hey

    Once I had a simular problem and it turned out to be the SD card. Maybe try with a new card

    Anders

    #4291
    Author Image
    Henrik Kurka
    Participant

    Thanks Anders, but now I tried again by using
    sudo dd if=imagefile_512MB.img of=/dev/disk1 bs=1m
    instead of
    sudo dd if= imagefile_512MB.img of=/dev/rdisk1 bs=1m

    ..and now it works :) Not sure why, but I guess not using raw is more fail safe?

    #4293
    Author Image
    Anders Søborg
    Key Master

    Hi

    No actually I think that if you don’t use raw then it takes forever… Anyway glad you got it working…

    Anders

    #4294
    Author Image
    Henrik Kurka
    Participant

    Actually it didn’t take that much longer time. I prefer working over fast ;)

    Cool to have Monobrick running now. Looking forward to play with it!

    #4295
    Author Image
    Anders Søborg
    Key Master

    Happy coding

    Anders

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Posted in

Make a donation