Problems with AbsoluteIMU-ACG from Mindsensors

HomeForumsMonoBrick EV3 FirmwareProblems with AbsoluteIMU-ACG from Mindsensors

Tagged: ,

This topic contains 0 replies, has 1 voice, and was last updated by Author Image Benjamin Minixhofer 12 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #5594
    Author Image
    Benjamin Minixhofer
    Participant

    Hello,

    I need the AbsoluteIMU-ACG for a project, but reading a register with e.g ReadRegister((byte)I2CRegisters.XGyroDataLSB, 6); always returns the register in decimal notation as first byte and 0 on the other bytes. The same happens when trying to read tilt or compass values.
    I tried updating the .dll, updating the firmware and the ReadAndWrite function but none of them worked. I also made sure that the i2c address is correct(0×22). When tested in the official LEGO environment, the sensor works just as expected.
    I’m using the code from this thread.

    Thanks in advance,

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

Posted in

Make a donation