MonoBrick Tunnel for Android 5.0.2 Issue

HomeForumsMonoBrick Communication LibraryMonoBrick Tunnel for Android 5.0.2 Issue

Tagged: ,

This topic contains 2 replies, has 3 voices, and was last updated by Author Image Barkeley Barkeley 1 year, 8 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #5413
    Author Image
    nato logic
    Participant

    I have been using MonoBrick Tunnel for Android for several months now and it has been working perfectly until recently. After I upgraded the Android device to 5.0.2 (I was running 4.4) I found that the app crashed whenever I attempted to access the “Settings” menu (the rightmost of the 3 buttons in the app).

    Furthermore I found myself unable to stream video to Windows MonoBrick Remote from the tunnel app even when all other functions (motor control, sensor reading) worked perfectly. I am not sure if this is a related issue, because the video streaming worked (albeit on a different computer) when I ran Android 4.4.

    Reinstalling the app was no help and just cleared the NXT brick from being a connected device, rendering the tunnel totally useless…oops.

    I have no means of “downgrading” back to 4.4 and I was wondering if anyone else had similar issues or a solution.

    Thanks!

    #5425
    Author Image
    Anders Søborg
    Key Master

    Hi there

    Sorry to hear that the tunnel is no longer working. Currently I am working on the EV3 firmware so an update is not the top priority. But if you are interested the code for the tunnel can be found here. You need Xamarin Android to compile the whole thing.

    /Anders

    #5539
    Author Image
    Barkeley Barkeley
    Participant

    I can confirm I couldn’t make work neither the android remote nor the android tunnel with android 5.0 and over (tried on 3 different cellphones). All was fine using an older cellphone with android 4.1.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Posted in

Make a donation