Exception during execution

HomeForumsMonoBrick EV3 FirmwareException during execution

This topic contains 0 replies, has 1 voice, and was last updated by Author Image Skyfighter65 9 months, 2 weeks ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #5671
    Author Image
    Skyfighter65
    Participant

    Hey, me again.
    I do have the following problem:
    When I compile my program with VisualStudio, I’m getting an error saying “Exception during execution” when I try to run it via the Brick.

    However, when I write the same Program with MonoDevelop (on my Raspberry Pi) everything works perfectly.

    Also when I run the VisualStudio program via SSH, everything works perfectly.
    That’s pretty confusing to me.
    I will use Xamarin/MonoDevelop if there’s no other solution, but I would prefer to use VisualStudio.

    The program is pretty simple:

    
    using System;
    using MonoBrickFirmware;
    using System.Threading;
    using MonoBrickFirmware.Display;
    
    namespace Ev3_framework4
    {
        class Program
        {
            static void Main(string[] args)
            {
                Console.WriteLine("Hello World from Visual Studio");
                Thread.Sleep(10000);
            }
        }
    }
    

    EDIT:
    Using Mono on my pc also does not work.
    It could be beacuse of Mono and Visual Studio creating a .pdb file instead of a .mdb file in bin/debug. The Mono version on my Raspberry Pi, which I made the working version with, creates such a .mdb instead of the .pdb.

    EDIT 2:
    I don’t know what happened, but it’s working right now with my Visual Studio version using the Brick.

    • This topic was modified 9 months, 2 weeks ago by Author Image Skyfighter65.
    • This topic was modified 9 months, 2 weeks ago by Author Image Skyfighter65.
Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

Posted in

Make a donation