Cannot change Xamarin Active Runtime

HomeForumsMonoBrick EV3 FirmwareCannot change Xamarin Active Runtime

Tagged: ,

This topic contains 11 replies, has 3 voices, and was last updated by Author Image Samuel Otero 2 years, 2 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #5319
    Author Image
    Samuel Otero
    Participant

    Hello

    Please guys, I need your help. I want to set up my environment, so I can start using this wonderful api asap.

    I am following the instructions of this page: http://www.monobrick.dk/guides/firmware-guides/installing-the-xamarin-studio-add-in-for-use-with-monobrick-firmware/

    I get stuck in the part when I need to change the Active Runtime. The option seems to not exists anymore under Menu -> Project tab. I tried to search for a work around without avail. I know that it didn’t magically pointed to the right runtime, because when I try to debug using Monobrick, I get the error back that I need to use the Mono Runtime… but there’s no option anymore to actually change it!! Example!

    Any help will be very much appreciated!! Thank you!

    #5320
    Author Image
    Anders Søborg
    Key Master

    Hi there

    Did you install the mono runtime?

    /Anders

    #5321
    Author Image
    Samuel Otero
    Participant

    Yes sir, I did. Downloaded and re-installed just in case from here: http://www.mono-project.com/download/#download-win

    I don’t know what’s wrong. The option just doesn’t appear. Just in case it helps, I am running Xamarin Studio 5.7.2 version in a Windows 8.1 64 bits OS.

    Damn… any help??? :(

    • This reply was modified 2 years, 4 months ago by Author Image Samuel Otero.
    #5323
    Author Image
    Anders Søborg
    Key Master

    Hi there

    Try to create a “Hello world” console program/project (not a MonoBrick project). Are you able to switch then…

    /Anders

    #5325
    Author Image
    Samuel Otero
    Participant

    I did, and nothing changed. I was able to run the Hello World and everything, but no option appears to change the runtime. Perhaps I should try to downgrade Xamarin in some way? Are you able to change runtimes as you show in your tutorial using the last version of Xamarin? Windows 8.1 64bits? What about the framework target? It has anything to do with it? I’m just trying to pass this obstacle, cuz I really want to get into this.

    #5326
    Author Image
    Samuel Otero
    Participant

    Any help?????

    #5327
    Author Image
    Samuel Otero
    Participant

    Ok, I think I found a solution. Now what I need is your feedback, in order to know if I can continue working like this, or you will not recommend what I did, for some reason.

    I just went to the project option, and changed the Target Runtime, from Mono / .Net 4.5 to Mono / .Net 3.5 and now it seems to work, or at least, I can run it with “Mono Soft Debugger fro Monobrick”.

    Setting changed:

    Now when I run it, it shows and error saying that InfoDialog class doesn’t have a constructor accepting just two arguments, but that’s fine, as the definition of the constructor at the class, clearly shows that it waits for 3 arguments.

    I will be waiting some feedback from your part, in order to know if it is ok to develop with this settings.

    Thank you Anders!

    #5328
    Author Image
    Anders Søborg
    Key Master

    Hi there

    I tried this at work using Xamarin Studio 5.7.2 and a Windows 7 64 bit version. And there was no problem. So why you are having this issue I can not say. But I found this solution that indirectly talks about your problem – and the solution seems to be that you should

    specify the default runtime in the MonoDevelop global options: Preferences->.NET Runtimes

    Anyway compiling with 3.5 might give you some problems such as the what you have just experienced yourself. The reason that you all of a sudden can not compile the default program that comes with plugin is due to the fact that default parameters are a feature that was introduced in C# 4.0. Why you are able to get the plugin to work when selecting setting the target frame work to 3.5 I can not explain. I hope that you find a way through.

    /Anders

    #5331
    Author Image
    Samuel Otero
    Participant

    :/ but it is specified already as the default at Xamarin…

    Image

    Should I specify that in other place?

    Sorry if I’m bothering too much. Have a nice one.

    • This reply was modified 2 years, 4 months ago by Author Image Samuel Otero.
    #5352
    Author Image
    Anders Søborg
    Key Master

    Hi there

    I tried this on my work computer running Windows 7 and the same Xamarin Version as you and I was able to get it working. From you last screenshot it seems that you did not install the Mono Runtime. What happens when you type mono in a terminal?

    /Anders

    #5375
    Author Image
    Steffeler
    Participant

    To answer the initial question: You not only have to install the mono runtime, you also have to add it in Xamarin at Options->.NET Runtimes->Add->(Folder where Mono ist installed). After that you can change the Active Runtime.

    Attachments:
    You must be logged in to view attached files.
    #5380
    Author Image
    Samuel Otero
    Participant

    At first I imagined that this was the problem, but Xamarin wont let me to add Mono Runtime at that screen so I thought that this was not the problem then.

    Today I re-opened Xamarin and it ask me to update itself. I updated Xamarin to the last version, unistalled Mono, re-installed it again and it appeared then in that list of .Net runtimes.

    Now it is running flawless. Steffeler, thank you so much. I really, really appreciate your answer.

    • This reply was modified 2 years, 2 months ago by Author Image Samuel Otero.
Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Posted in

Make a donation