Reply To: Only SensorPort.In1 works? (solved)

HomeForumsMonoBrick EV3 FirmwareOnly SensorPort.In1 works? (solved)Reply To: Only SensorPort.In1 works? (solved)

Author Image
Rich Champeaux

Great, I’m glad I was of help. I’m new to the open source scene, so I don’t know all the etiquette and protocol and didn’t even think about the possibility of fixing it myself. I will have to read up on pull requests on github. Also, I found it only through code inspection and looking for inconsistencies, not because I knew what it was supposed to do.

However, what about the second issue I identified? It looks like you are trying to read a byte, clear a bit, and then write it back. However you are not reading and writing from the same place. You are reading from “port” and writing to “UartStatusOffset+port”

I would like to understand more about the lower level interactions with the devices. Where are you getting your information about how to communicate with the devices?

Posted in

Make a donation